
 

Print Manager Plus
®
  

Print Manager Plus Database Backup Procedure and Recommendations 

Backup 
Recommendations 

 

 

Software Shelf International, Inc. 
601 Cleveland Street, Suite# 710 
Clearwater, FL 33755 United States 
Phone: 727-445-1920 Fax: 727-445-9223 
Sales Email: sales@softwareshelf.com 
Support Email: support@softwareself.com  

Software Shelf International, Inc. 
Vitality House, 2 - 3 Imberhorne Way 
East Grinstead, West Sussex, RH19 1RL, United Kingdom 
Phone# +44 1342 310950 
Sales Email: sales@softwareshelf.co.uk 
Support Email: support@softwareself.co.uk  

© 1996-2009 Software Shelf International, Inc. All Rights Reserved. Software Shelf, SoftwareShelf.com and Print Manager Plus are trademarks or registered trademarks owned by Software Shelf International, Inc. 

 

 

 

INTRODUCTION: 
This guide provides basic examples and details to assist in backing up the Print Manager Plus database.  Print 
Manager Plus is designed to use either an MS Access, or MS SQL Database type.  The process for backing up SQL 
Databases can vary depending on the version of SQL being used, and how that was setup.  Your database may not 
be on the print server if a SQL Server within your network is being used. 
 
MS Access databases are simple files named PMPQuota.mdb that can be backed up. 
 
 
 
 
 
 
 
 
 

DETERMINING DATABASE TYPE 
The first step in ensuring a successful database backup, is checking which type is being used.  It is recommended to 
never assume the type. 
 

Checking the Type: 
 

1. Open the Print Manager Plus Administrator on one of your Print Servers. 
 
  

2. Within the program, go the File menu and choose Database Connection 
 

 
 
  

3. The dialog that appears will provide the database type, and also information on where that database 
is located (Access Database), or where it is hosted from (SQL Databases). 

 

MS Access Database Example MS SQL / MSDE Database Example 

  

 

Disclaimer: 

The Print Manager Plus product, Software Shelf International Inc, and its staff are not responsible for the proper 
and safe backup of your database.  This document provides recommendations and guidelines to assist a qualified 
Technician or Database Administrator with the backup procedure. 
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BACKING UP AN MS SQL/MSDE DATABASE WITH THE MANAGEMENT STUDIO 
Once you have verified that you are using an MS SQL/MSDE database (see previous section) you can proceed to 
create a backup of that database.  Creating a backup file is usually done using the SQL Management Studio from 
Microsoft.  If you do not own this studio, Microsoft provides a free version called the SQL Management Studio 
Express.  The following demonstrates a sample process of backing up the database.  If you are uncertain if this 
process is correct, please contact your Database Administrator or Software Shelf Support. 
 
 
 
 
 

Creating the Backup: 
Ensure the SQL Management Studio is installed on the server hosting the Print Manager Plus database.  If 
not download and install it. 

  
1. Determine your SQL Instance Name: 

 
 

a. Open the Print Manager Plus Administrator on one of your Print Servers.  Within the 
program, go the File menu and choose Database Connection. 

 

  
 
 

b. Within Database Connection, note the entire string listed in the Microsoft SQL/MSDE 
Database Server box.   
 
 

c.  
 

 
 
 
  
 

Plain Server Instance Sample Specific Server + Instance Name Sample 

  

Obtaining SQL Management Studio Express: 
This management studio can be obtained free of charge from http://www.microsoft.com/downloads.   

SQL Instance Names:  
This will either be a Server Name such as. Examples: DBSERVER or (Local). 

 
In many cases where a specific SQL instance is used, it will a server name + and Instance Name.   
Examples: (Local)\PMP or DBServer\Production. 

http://www.microsoft.com/downloads
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2. Open the SQL Management Studio Express: 
Your SQL Management Studio will typically be in your start menu under Microsoft SQL Server 200X 
depending on which version is installed. 
 

 
 
 
 
  

3. Connect to your Instance: 
Upon opening the studio, it will ask for a Server name.  Within this box is where you will want to 
type, or paste in your Instance name determined from step 1.  Once entered, click Connect. 
 

 
 
 
 
 
 
 
  
 

Permissions: 

By default we recommend using Windows Authentication.  This requires the user running the 
management studio be an Administrator of that server, or have been otherwise granted database 
permissions. 
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4. Browse to the Print Manager Plus Database: 
Now that you have connected to that SQL Instance, you will want to browse the Databases folder 
and find the database named PrintManager. 
  

 
 
 
 
 

5. Open the Backup Dialog: 
Next, right click on the PrintManager database and open Tasks > Backup.  This will open a new 
dialog with backup options. 
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6. Configure Backup Settings and Run: 
Within the dialog will be a variety of backup settings.  Typically everything can be left as it is 
defaulted, and you can click OK.  Once OK is clicked it will create the backup; this may take several 
minutes 
 
Below is a reference of some of the basic options.   
 

           

 
 
 
 
 
 
 
 
 

Database being Backed up: 

Should be PrintManager 

Backup Type: 

Full recommended 

Destination: 

Specifies where the backup file created will be 
saved.  The backup location will default to the 
Microsoft SQL Backup Folder. 
 
Additional Backup locations can be added. 

Advanced Options: 

A variety of additional options are available, but are beyond the scope of this example.  For 
advanced backup options, please consult Microsoft SQL Server Documentation or a qualified 
Database Administrator. 
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BACKING UP AN MS SQL/MSDE DATABASE FILES MANUALLY 
As an alternative to backing up MS SQL/MSDE databases using the SQL Management Studio, one can also backup 
the files manually.  The Print Manager Plus database by default consists of a PrintManager.mdf and 
PrintManager_Log.LDF file.  Advanced SQL configurations may have other or additional files, if you believe you 
may have this, please consult your Database Administrator. 

 
 

Creating the Backup Manually: 
Go to the server that is hosting the Print Manager Plus database and perform the following steps. 
 
 
 

1. Determine which server is hosting your database: 
First you will want to verify which server is hosting your database. In many cases this is the same 
server as Print Manager Plus. 
 
 

a. Open the Print Manager Plus Administrator on one of your Print Servers.  Within the 
program, go the File menu and choose Database Connection. 

 

  
 
 
 

b. Within Database Connection, note the server name in the Microsoft SQL/MSDE Database 
text box.   
 
If there is a backslash, then the server will be the portion before the backslash.  In the below 
example, the server hosting the database is named PrintServer. 

 

 
  

 
 
 

Servers named "(Local)" 
 
If your server says (Local) 
then the SQL database is 
hosting locally on that 
server. 
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2. Stop the Print Manager Plus Service: 
Within Administrative Tools > Services you will want to locate the service named Print Manager 
Plus and stop it. 
 

 
 
 
  

3. Stop the SQL Server Service: 
Next you will need to the stop the SQL Service hosting your database.  The name of the service 
running the SQL Service may vary, but most installs of Print Manager Plus SQL Server (PMP).  
Below are some typical names to check.  If you are having difficulty determining the SQL Service 
running your database, please consult your Database Administrator. 
 
 

 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Locate the Database Files: 
Print Manager Plus typically has two database files; they are PrintManager.mdf and 
PrintManager_Log.ldf.  These are typically stored at one of the following locations: 
 
 

SQL 2005/2008 Express & Standard Editions: 
Default Location: C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data 
 
 
SQL 2000/MSDE Editions: 

  Default Location: C:\Program Files\Microsoft SQL Server\MSSQL\Data 
 

  
 

SQL Service Name Examples: 
 
"SQL Server (PMP)"  (Typical for PMP Installations using SQL Express - Most Common)  

 
"MSSQLServer"   (Typical for SQL 2000 and MSDE Installations) 
"SQL Server (MSSQLSERVER)" (Typical for SQL Full 2005/2008 Installations) 
"SQL Server (SQLExpress)" (Typical for SQL 2005/2008 Express installed manually) 
"SQL Server (InstanceName) (Typical for SQL 2005/2008 Using non-default instance name 
"MSSQLServer$InstanceName" (Typical for SQL 2000/MSDE using non-default instance) 
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(Step 4 Continued on Next Page) 

 
(Step 4 Continued from Previous Page) 

 
 
 Sample Stored in SQL 2005 Express: 
 The following is a sample of PrintManager database files being selected. 

  
 
 
 
 
 
 
 
 
 

 
 
 

 

 
5. Create a Backup Copy 

Once the files have been located, it is recommended to COPY them to another safe directory for 
backup.  Off server backups are always recommended in case of total server failure. 

 

Warning: 
If Print Manager Plus, or SQL have been installed multiple times using multiple 
databases, you should be careful to ensure you are backing up the current database.  
ALL locations and instances of PrintManger.mdf and PrintManager_log.ldf should 
be located and backed up on the server to ensure a safe backup. 
 
If you uncertain that you have located the correct current database, then we 
recommend using the SQL Management Studio to perform a backup as described in 
the previous section. 

Important: 
Ensure that only a copy is 
made, and that the original 
database files are not 
removed from their original 
location. 
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6. Start the SQL Server Service: 
Next you will need to start the SQL Server service that you had stopped in step 2. 
 

 
 
 

 

7. Start the Print Manager Plus Service: 
Once the SQL Service is back up and running, you will want to start the Print Manager Plus service. 
 

 
 
 
 

8. Restart Additional Services & Workstation Connected Printer Agents: 
Other print servers running Print Manager Plus and the Workstation Connected Printer Agents may 
be adversely effected by bringing the Database Offline and Online for backup.  It is recommended 
that all other servers running the Print Manager Plus Service or Workstation Agent have their Print 
Manager Plus service restarted, or that the machine itself is restarted. 
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BACKING UP AN MS ACCESS DATABASE 

Making a backup copy of an MS Access database is a relatively easy backup process of one file named 

PMPQuota.mdb.   

 

 

 

 

1. Check the Location of your MS Access Database 
First you will want to verify the location of your MS Access Database. 
 
 

a. Open the Print Manager Plus Administrator on one of your Print Servers.  Within the 
program, go the File menu and choose Database Connection. 

 

  
 
 
 
 

b. Within Database Connection, note the path to the PMPQuota.mdb file that is listed within the 
Microsoft Access Database text box. 
 
In this example, it is located in the System32 folder which is the default location. 
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2. Locate the Database File: 
Next you should browse to the folder your MS Access database is in, and locate the file. Below is an 
example of it being found in its default location. 

 

 
 
 
  

3. Make a Copy of the File in another location: 
You will want to make a copy of the file elsewhere.  It's always recommended that backups be stored 
safely, and off server in case of total server failure. 
 
 
Sample of the Copied File: 

 
 
 
  
 

 

Important: 
Ensure that only a copy is made, and that the original database files are not removed from 
their original location. 
 


